Browser Requirements

Basic Browser Requirements

Windows Users:
Our site works best with Internet Explorer 8.x or above, or Firefox 32.x or above, or Chrome 32.x or above. Some features may not work properly if you are using a different browser, and checkout will not be possible.

Macintosh Users:
If you are using Mac OS X 10.8 or above, you may use Apple’s Safari browser. Otherwise, you may need to use a browser such as Firefox or Chrome to receive advertised discounts and complete your shopping.

You may download the latest compatible browsers by following the links below.

Cookies

In order to use the harryanddavid.com Website, your Web browser must be set to accept cookies. To set your browser to accept cookies, look under “Preferences” or “Options” in your browser.

JavaScript

In order to use the harryanddavid.com Website, your Web browser must be configured to use JavaScript. To set your browser to use JavaScript, look under “Preferences” or “Options” in your browser.

Pop-Up Windows

Our site uses pop-up windows to enhance your shopping experience. Please turn off any software that disables such windows, so that you will be able to shop.

Welcome. Now that HarryandDavid.com is part of a larger family of brands, we're excited to offer you an enhanced online experience to shop many brands with one easy checkout process, and we invite you to enjoy special savings with our Celebrations Passport and Celebrations Rewards programs.  Learn More